Les 2 ou 3 p'tits bugs du forum (correction éventuelle)

Si vous avez des suggestions pour améliorer le site web venez ici !

Les 2 ou 3 p'tits bugs du forum (correction éventuelle)

Message par Lyan53 le 05 Sep 2011, 13:51

Re tout le monde,

J'ai remarqué en parcourant le fora qu'il y a 2 ou 3 petites bricoles qui buggent, c'est pas bien méchant et n'empêche en rien l'utilisation de ce dernier mais bon au cas où, voilà quelques petites astuces ou conseils pour tenter d'y remédier ;)
............................................

Tout d'abord pour le bas du forum , j'ai remarqué l'espace qu'il y a au niveau de footer sur le style
>> http://nsa27.casimages.com/img/2011/09/ ... 146734.png

En théorie c'est corrigeable à partir du css, dans ce dernier il doit y avoir une entrée :
Code : Tout sélectionner
.bottom-left {

Avec comme contenu au moins la ligne :
Code : Tout sélectionner
    background-position: 0 -20px;

Normalement si je ne me plante pas en ajoutant la ligne :
Code : Tout sélectionner
    margin-top: -20px;

avant le
Code : Tout sélectionner
}

à la fin ça devrait corriger le souci ;)

.............................................

Ensuite j'ai vu dans l'UCP (User Control Panel) qu'il y a dans le profil une entrée pour le "genre"
http://nsa28.casimages.com/img/2011/09/ ... 194767.png

Ceci est un mod phpbb3 qui a été installé car ça n'est pas présent nativement dessus

Les entrées entre crochets (ex/ { GENDER }: ) signifient que ces dernières ne sont pas interprétées dans le pack de langue du forum (à priori)

Ce mod devait être fait pour un forum en anglais sans inclure la pack de langue FR ce qui fait que du coup , ce dernier est manquant et comme le forum est réglé sur le langage FR, ces entrées ne peuvent être interprétées

Il faudrait donc installer un pack de langue FR pour ce mode (ou alors s'il n'existe pas le pack de langue anglais puis l'ajouter dans la partie FR)

Si je ne me plante pas non plus, le genre devrait également apparaitre dans notre profil des posts :
ImageImage

J'ai mis un exemple tiré de mon propre forum, il se peut que le pack de langue y soit également pour quelque chose , à voir au niveau des images dans le template (il doit y avoir des images FR normalement et si le pack de langue FR était absent du mod, lors de son installation ces images n'ont été que se mettre que dans le dossier EN et non dans le FR)

Reste un truc que je ne m'explique pas , on a pas de terme entre crochets à ce niveau là, bref à vérifier tout ça ;)

................................................

Dernier point relativement simple à corriger, le fameux icône "online" dans les profils, il doit se trouver en 3 endroits (bien que je ne peux montrer que 2 exemples en image actuellement puisque j'ai ma boîte MP vide ^^)

Le profil dans les topics >> http://nsa27.casimages.com/img/2011/09/ ... 818172.png
Le profil perso >> http://nsa27.casimages.com/img/2011/09/ ... 740104.png
Et le dernier, le profil dans les MP >> (dont je n'ai pas de screenshot mais qui ressemble à celui des topics)

Pour corriger ce souci qui est dû au passage des profils de la droite (nativement sur phpBB3) vers la gauche, il suffit juste de changer le sens de cette image (y'a possibilité de faire plus complexe et personnalisé mais on va aller au plus simple ^^)

Il suffit juste de remplacer l'image "icon_user_online.gif" située dans : styles/(nom du style installé)/imageset/fr/ >> ici <<

Par l'image ci dessous fournit en pièce jointe et le tour est joué ;)

Si vous avez des questions n'hésitez pas :)
Pièces jointes
icon_user_online.gif
icon_user_online.gif (499 octet(s)) Consulté 3123 fois
Image
Avatar de l’utilisateur
Lyan53
Petit Joueur
 
Message(s) : 15
Inscription : 04 Sep 2011, 21:24
Localisation : Mayenne


Re: Les 2 ou 3 p'tits bugs du forum (correction éventuelle)

Message par webmaster le 05 Sep 2011, 18:05

Merci d'avoir énuméré tout ces problèmes.
Les mises à jour PhpBB ont effacé certaines lignes sur les genres et donc le module n'est plus correctement installé et je n'ai pas encore eu le temps de le remettre.

De toute façon, le site et le forum vont subir une grosse opération de modification qui arrivera (je l'espère) avant 2012.
Si j'ai le temps de régler les petits bugs que tu as cité, je le ferai, sinon il faudra attendre la grosse mises à jour.
[*_Webmaster_*]
Avatar de l’utilisateur
webmaster
Chef De Famille
 
Message(s) : 412
Inscription : 23 Juil 2008, 12:50
Localisation : Dans le manoir Himuro


Re: Les 2 ou 3 p'tits bugs du forum (correction éventuelle)

Message par Lyan53 le 05 Sep 2011, 23:04

Arf les MàJ auto c'est bien mais faut pas les utiliser sur les templates modifiés sinon ça déconne , faut les faire manuellement celles pour les styles car les templates modifs (celui-ci étant un dérivé de prosilver) peuvent comporter des entrées dans le css ou dans les fichiers html du style , totalement différentes que les entrées d'origine :)


Sinon pas de souci , tu gères ça comme tu le sens, je signalais ça juste au cas où les soucis auraient étés difficiles à identifier (c'est pas toujours évident de s'y retrouver dans le code de phpBB3 ^^)

Bon courage pour les modifs à venir dans tous les cas ;)
Image
Avatar de l’utilisateur
Lyan53
Petit Joueur
 
Message(s) : 15
Inscription : 04 Sep 2011, 21:24
Localisation : Mayenne



Retour vers Suggestions et problèmes

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 1 invité



cron